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  Image Processing 
  
 Image Restoration 
 
   Deconvolution 
  
 Image Enhancement 
 
  Look up tables 
  Brightness&Contrast 
  Histogram stretching/equalization 
  Arithmetic Operations 
  Background /Shading Corrections 
  Filtering 
   Convolution 
   Noise Reduction and Smoothing 
   Feature Enhancement 
    Frequency Domain  
 
 Other Processing 
 
  Segmentation, Stitching, Color Registration, Tracking,  
  Particle Analysis 
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Image Enhancement 
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1. Image Enhancement 
 

What for? 
 
Enhances visual appearance of image features 
 
Helps to reduce noise 
 
Sometimes is needed before image segmentation 
 
 
 
 
Attention! 
 
It modifies pixels values, use with caution! 

Final image must represent the original information 

Always use a copy of the original file 

For publication, manipulations should be indicated 

Check journal guidelines regarding image processing 

Ethics in image processing! 
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 1.1 Lookup Tables 
 

  Image>Lookup tables 
 

Easiest way to emphasize differences in intensity 
Only modifies image appearance, not pixel values 
 
 
 
 
 
 
 
 
 
 

Have fun and create your own Lookup Table!  Image>Color>Edit LUT 

1. Image Enhancement 
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1.2 Brightness&Contrast. Levels. Gamma 

 Linear Adjustments 

  Image>Adjust>Window/Level 

  Image>Adjust>Brightness&Contrast 

Linear relationship between image intensity and display intensity  

 

  

 

 

 

 Non-Linear Adjustments: Gamma 

  Process>Math>Gamma… 

Changes in pixel values depend on a non-linear function. 

Useful to enhance low pixel values without saturating high ones 

1. Image Enhancement 
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1.3 Histogram Adjustment I 
Histogram: Number of pixels at each intensity value 

Analyze>Histogram 

 

(Global) Histogram Equalization 
Process>Enhance Contrast>Equalize Histogram 

Attempts to perform an equally redistribution of pixel values along the image range 
 
 
 
 
 
 
 
 
Regions of Interest (ROIs) can be used to select image areas before equalization  

1. Image Enhancement 
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1.3 Histogram Adjustment II 

CLAHE-Contrast Limited Adaptive Histogram Equalization 

  Process>Enhance Local Contrast (CLAHE) 
 
 
Local Histogram Equalization 
 
Does not apply histogram equalization on the whole image but on image blocks 

 
   

 

 

 
 

 

1. Image Enhancement 
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1.3 Histogram Adjustment III 
 

Histogram Normalization (Stretching) 
Process>Enhance Contrast>Normalize 

Normalizes histogram to maximum and minimum intensity values 
 
Helps to establish the same intensity threshold between images with different 
intensity levels (for example, due to photobleaching). 
 

1. Image Enhancement 
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1.4 Arithmetic Operations I 
 

Work on a pixel by pixel manner 

 

With a Constant Value  

 
Process>Math 

 

Add, Multiply, Divide 

Use to adjust image brightness 

Subtract 

Use to remove background 

1. Image Enhancement 

x 2 
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1.4 Arithmetic Operations II 

 
Between two images 

 

Process>Image Calculator 

Plugin Calculator Plus 

 

 

Add to combine information 

Subtract to extract certain image areas 

Division to apply shading correction 

Average to reduce noise (stack needed) 

 

1. Image Enhancement 
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http://rsb.info.nih.gov/ij/plugins/calculator-plus.html


Arithmetic Operations Between 2 images Examples 

 
 

‘Add’ to combine not usual look up tables 

1. Open both files and change Look up tables: Image>Lookup tables 

2. Go to Process>Image Calculator and select Add as the operation 

3. Numerator image must be RGB. If not, first change it going to Image>Type> RGB Color 

 

 

 

 

 

 

‘Division’ to apply shading correction 

1. Open imagen and Shading image (acquire an area of the coverslip without sample with exactly the same illumination settings).  

2. Go to Process>Image Calculator and select Divide as the operation. Use Shading image as Denominator. 

3. For proper visual display use the 32-bit(float) result checkbox 

4. Change to 8Bit to reduce image data: Image>Type> 8-bit 
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 1.5 Background/Shading Corrections I 

  

 Even Background 

 - Subtract average background from image (Process>Math>Subtract) 

 - Macro BG Subtraction from ROI 

1 Image Enhancement 
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1.5 Background/Shading Corrections II 

 

Uneven Background/Shading Correction 

 

- Rolling ball algorithm  (Process>Subtract Background) 

- Plugin Fit Polynomial 

- Plugin Nonuniform Backgroun Removal 

- BandPass filter (Process>FTT>BandPass filter) 

- Plugin Shading Corrector (a flat-field image is needed) 

- Divide original image and ‘shading image’ 

 

Additional information  

 

1. Image Enhancement 
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http://imagejdocu.tudor.lu/doku.php?id=plugin:filter:fit_polynomial:start
http://imagejdocu.tudor.lu/doku.php?id=plugin:filter:fit_polynomial:start
http://www.cs.unc.edu/~cquammen/imagej/nonuniform_background_removal.html
http://www.cs.unc.edu/~cquammen/imagej/nonuniform_background_removal.html
http://www.cs.unc.edu/~cquammen/imagej/nonuniform_background_removal.html
http://www.cs.unc.edu/~cquammen/imagej/nonuniform_background_removal.html
http://rsb.info.nih.gov/ij/plugins/shading-corrector.html
http://imagejdocu.tudor.lu/doku.php?id=howto:working:how_to_correct_background_illumination_in_brightfield_microscopy
http://imagejdocu.tudor.lu/doku.php?id=howto:working:how_to_correct_background_illumination_in_brightfield_microscopy


Background/Shading Corrections Examples 

 
 

Rolling Ball algorithm 

1. Open your file and change appearance for better visualization if necessary: Image>Lookup tables 

2. Duplicate your original image: Image>Duplicate… 

3. Apply ImageJ/Fiji background subtraction tool on you duplicate: Go to Process>Subtract Background 

Information on this tool can be found here: http://rsb.info.nih.gov/ij/docs/guide/146-29.html#toc-Subsection-29.14 

For this example, a Radius of 30 has been used. 

 

 

 

 

 

Fit Polynomial Plugin 

1. Download and install Fit Polynomial plugin. 

2. If necessary, open your file and change appearance for better visualization: Image>Lookup tables 

3. Duplicate your original image: Image>Duplicate… 

4. Open Fit Polynomial tool: Plugins>Fit Polynomial 

Information on this tool can be found here: 

 http://imagejdocu.tudor.lu/doku.php?id=plugin:filter:fit_polynomial:start 

Move the sliders until a good correction is got 

This plugin works well for transmitted and DIC images correction  
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http://rsb.info.nih.gov/ij/docs/guide/146-29.htmltoc-Subsection-29.14
http://rsb.info.nih.gov/ij/docs/guide/146-29.htmltoc-Subsection-29.14
http://rsb.info.nih.gov/ij/docs/guide/146-29.htmltoc-Subsection-29.14
http://rsb.info.nih.gov/ij/docs/guide/146-29.htmltoc-Subsection-29.14
http://rsb.info.nih.gov/ij/docs/guide/146-29.htmltoc-Subsection-29.14
http://rsb.info.nih.gov/ij/docs/guide/146-29.htmltoc-Subsection-29.14
http://rsb.info.nih.gov/ij/docs/guide/146-29.htmltoc-Subsection-29.14
http://imagejdocu.tudor.lu/doku.php?id=plugin:filter:fit_polynomial:start
http://imagejdocu.tudor.lu/doku.php?id=plugin:filter:fit_polynomial:start


 
 

Involves a group of neigbour pixels to create a new pixel value 
 
Used to smooth the image, remove noise or feature/edges enhancement 
 
Filters apply an algorithm or a convolution kernel 

 

1.7 Filtering 
1. Image Enhancement 
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 1.7.1 Convolution 
 

Mathematical operation applied to a group of pixels  

Intensity of each output pixel is a function of the intensity values of its neighbours 

Size of the group of pixels involved depends on size of the Convolution Kernel, 
a square array, usually 3x3, 5x5, 7x7, with different numerical values 

 

 

 

 

 

 

 

 

1. Image Enhancement  / 1.7 Filtering 

Create your own convolution kernel: Process>Filters>Convolve 
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 1.7.2 Denoising and Smoothing 

Filters….What for? 

To reduce noise to improve image quality 

To facilitate other processing such as thresholding 

To remove small isolated objects 

 

Gaussian Blur filter 
Process>Filters>Gaussian Blur…/Gaussian Blur 3D… 
 
Mean Filter 
Process>Filters>Mean…/Mean 3D… 
 
Median Filter 
Process>Filters>Median…/Median 3D… 
Does not smooth object edges as much as Gaussian filter or Mean Filter 
Process>Noise>Despeckle  (Median 3x3) 

1. Image Enhancement  / 1.7 Filtering 
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 1.7.2 …Some other denoising tools 

 

Anisotropic Diffusion Filter 
http://fiji.sc/Anisotropic_Diffusion_2D  

 

 Sigma Filter Plus 
http://rsbweb.nih.gov/ij/plugins/sigma-filter.html 

 

 Non-Local Means Denoising  
https://code.google.com/p/ij-non-local-means/ 

 

 Kuwahara Filter 
http://rsbweb.nih.gov/ij/plugins/kuwahara.html 

1. Image Enhancement  / 1.7 Filtering 
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 1.7.3 Feature Enhancement 
 
 
 
 

Filters…What for? 

To highlight edges or fine details from images 

Spot detection 

Sharpen Filter 

  Process>Sharpen 

 Unsharp Mask 

  Process>Filters>Unsharp Mask… 

 Laplacian Filter 

  Plugins>Feature Extraction>FeatureJ>FeatureJ Laplacian 

 LoG (Laplacian of Gaussian) 
  Plugin LoG3D 
 
 

More information about Edge Detection in Segmentation section 

1. Image Enhancement  / 1.7 Filtering 
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http://bigwww.epfl.ch/sage/soft/LoG3D/


Spot Detection example I 
1- Download and install LoG3D plugin. 

http://bigwww.epfl.ch/sage/soft/LoG3D/ 

2- Open your file and change appearance for better visualization if necessary: Image>Lookup tables 

3- Duplicate your original image: Image>Duplicate… 

4- Apply ImageJ/Fiji background subtraction tool on your replica: Go to Process>Subtract Background 

Information on this tool can be found here: http://rsb.info.nih.gov/ij/docs/guide/146-29.html#toc-Subsection-29.14 

For this example, a Radius of 50 has been used. 

5- Apply LoG3D plugin on your background-corrected image for spot detection: Plugins>LoG3D 
 
For this example, a sigma X and Y of 1 was used. 
 

Raw Background subtracted LoG3D 
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Spot Detection example II 
 
6- For better visualization of result image change lookup table , Invert lookup table and modify Brightness&Contrast: 
 
    
 
 
 
  
        Image>Lookup tables 
        Image>Lookup tables>Invert LUT 
        Image>Adjust>Brightness/Contrast 
 
 
 
 
 
 
 
 
 
7- To compare both images (filtered and original), use the Synchronize windows tool (Analyze>Tools)  

Raw Filtered 
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 1.7.4 Filtering in the Frequency Domain 
 

Microscopy images are in the Spatial Domain (1pixel=1intensity value) 

FFT algorithm (Fast Fourier Transform) is used to transform images from 
Spatial to Frequency Domain (amplitudes and frequencies sines/cosines that 
added up will give the image) 

 

 

 

 

 

 

 
 
Process>FFT>FFT (Spatial domain to Frequency domain)  
Process>FFT>Inverse FFT(Frequency domain to Spatial domain) 

1. Image Enhancement  / 1.7 Filtering 

FFT 

Inverse FFT 
Spatial D. Frequency D. 
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 1.7.4 Filtering in the Frequency Domain 
 
What for?  
 
Correction of Periodic Artifacts 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Image Enhancement  / 1.7 Filtering 

FFT 

Inv. 
FFT 

Each image requires a different approach 
(Sometimes is not easy to find) 
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BandPass Filter 
 

Process>FFT>Bandpass Filter 
 
Works in the Fourier domain 
 
 
 
 
 
 
What for?  
 
Suppress Stripes 
 
Shading Correction 
 

 1.7.4 Filtering in the Frequency Domain II 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Image Enhancement  / 1.7 Filtering 
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FFT example 
Correction of Periodic Artifacts 

1. Open your file and change it to its Frequency Domain: Process>FFT>FFT 

In the frequency domain image, periodic artifacts will show up as a pattern of a few  bright star-like dots. When the artifacts are 
horizontally or vertically oriented, you will see horizontal and vertical bands along the center lines but not in the actual center of the 
frequency domain image. 

 

 

 

 

 

2. Double click on the Paintbrush tool: select Black Color and an appropriate brush width. 

In the frequency domain image, paint black the star-like dots.  

3. Return to the spatial domain: select your frequency domain image and go to Process>FFT>Inverse FFT. 

Periodic artifacts should appear attenuated. 

 

 

  

Serv
ici

o d
e M

icr
os

co
pía

 Ó
pti

ca
 y 

Con
foc

al 
(C

BMSO)



2. Segmentation 
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2. Segmentation 
“Division of the image in different segments or groups of pixels  

that share certain features” 

  What for? 

•  Extract meaningful information (getting rid of unwanted image elements) 

•  Simplify image data for later analysis 

 

 

 
Segmentation algorithms work considering 2 main Image Properties: 

• Discontinuity: algorithm looks for abrupt intensity changes. Example: Edge-
detection  algorithms.  

• Similarity: algorithm looks for image regions that have certain properties in 
common,  such as intensity values. Example: thresholding and region growing. 

Segmentation is a complex procedure!! Great variety of algoritms 
It will affect quality of analysis: Bad Segmentation=Bad Results!! 
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2. Segmentation Methods…a simplyfied classification
  

Thresholding 

Clustering  

Edge Detection 

Region Based  
Active Contours 

Watershed 

Trainable Segmentation  

Color Segmentation 

3D Segmentation 
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2.1 Thresholding 
Simplest and most commonly used 

Pixels are grouped in different categories depending on its intensity value 

Does not take into account spatial characteristics of the image 

 

Thresholding output = Binary Image 

 Binary image: a pixel can have only 2 values: Black (0) or White (255) 

  

2. Segmentation 

Raw Image     Binary Image     Thresholded 
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Important!! Threshold value has a strong influence in analysis 

 

Interactively (Visual Inspection) 

 Image>Adjust/Threshold 

 
 
  
 
 
 
 
 
 
 
 
 
 
  Caution!! Setting a threshold this way is subjective! 

2.1 Thresholding…How to stablish the Threshold Value? 
2. Segmentation 
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Algorithms for automatic selection 
 
 Global Threshold 

 Image>Adjust>Auto Threshold  
 Image>Adjust>Threshold 
 
But…gives bad results when image background is not even 
 
 

2.1 Thresholding…How to stablish the Threshold Value? II 
2. Segmentation 

Raw Global Local 

 Local Threshold 
 Image>Adjust>Auto Local Threshold 
 Adapts the threshold value on each pixel to the local image characteristics  
 Try if background, illumination or intensity pattern are uneven.  
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These operators modify the morphology of an object in a binary image 

Process>Binary> 

Erode: Shrinks the image. Holes became larger. Deletes small details 

Dilate: Enlarges object borders. Holes became smaller 

Open: Erode + Dilate. Smooths objects contourns, removes isolated 
elements, breaks thin connections 

Close: Dilate + Erode. Smooths objects contourns, fill small holes, joins 
breaks 
 

 

2.1.1 Morphological Operators on Binary Images I 
2. Segmentation 
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Process>Binary> 

Outline: Generates a one pixel wide outline of the objects 
 
Fill Holes: Fills holes in objects 
 
Skeletonize: Removes pixels from the edges of objects until they are 1pixel-
wide 
 
 
 
 
 
 
 
 
 
 
 
Process>Binary>Options Advance options to apply these morphological 
Operators 

2.1.1 Morphological Operators on Binary Images II 
2. Segmentation 

Serv
ici

o d
e M

icr
os

co
pía

 Ó
pti

ca
 y 

Con
foc

al 
(C

BMSO)



 

 
Can be used to improve segmentation after thresholding or edge detection 
 
 

Example 1: Improve image before Nuclei Counting 
 
 
 
 
 
 

 
 
Example 2: Analyze Neuron Morphology 
 

 
 

 

2.1.1 Morphological Operators on Binary Images. Applications? 

1.ThresholdBinary 
2.Fill Holes 
3.Open 

Skeletonize is used in many Fiji/ImageJ 
neuron morphology/sholl analysis plugins 
 
1.ThresholdBinary 
2.Skeletonize 

Neuron image: http://labs.biology.ucsd.edu/halpain/images.html 

2. Segmentation 
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2.1.1 Morphological Operators on Grayscale images? 

These operators modify the morphology of an object in a grayscale image 

 

 

Process>Filters>Minimum… Does grayscale Erosion 

Process>Filters>Maximum… Does grayscale Dilation 

 

Also… 

 

Grayscale Morphology plugin 

Morphological Filters in Fast Morphology plugin 

 

 

2. Segmentation 
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http://rsb.info.nih.gov/ij/plugins/gray-morphology.html
http://imagejdocu.tudor.lu/doku.php?id=plugin:morphology:fast_morphological_filters:start


2.1.2 Logical/Boolean Operations Between two images  
Process>Image Calculator 

Plugin Calculator Plus 

Work on a pixel by pixel manner 

Usually done between 2 binary images or a binary and a grayscale image 

Use to isolate specific structures of interest before image analysis 

AND OR XOR 

 
Result image is created based on these criteria: 
 
AND: Pixels that are on in both images (common elements) 
OR: Pixels that are in either image (all elements) 
XOR: Pixels that are in one or the other image but not in both (exclusive elements) 

 

2. Segmentation 
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 Works finding the edges or boundaries of objects in the image 

 Edges are image areas where a sharp change in intensity can be found 

 

 There are many filters and algorithms for edge detection: 

Process>Find Edges  

Plugin Canny Edge Detector  

Plugin Canny-Deriche filtering  
 
Plugin FeatureJ>FeatureJ Edges  

 
 
 
 
 

2.2 Edge Detection 
2. Segmentation 
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Wound Healing segmentation example I 
1. Open and duplicate your original image: Image>Duplicate… 

2. On your replica, apply any edge detection tool available. For this example Find Edges tool was used : Process>Find Edges 

3. Apply a gaussian blur filter to obtain a blurred-edge image. For this example a Radius of 2 was used. Process>Filters>Gaussian Blur… 

 

 

 

 

 

 

 

4. Apply an intensity threshold (Image>Adjust>Threshold) to detect the wound area and create a selection around the thresholded surface: 
Edit>Selection>Create Selection 

5. The selection was enlarged 8 pixels to fit selection borders to wound edge contours: Edit>Selection>Enlarge 

 

Edge detection 
+ 

Blurring 
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Wound Healing segmentation example II 
6. Add selection to ROI Manager for area measurement: Analyze>Tools>ROI Manager. 

 

 

 

 

 

 

 

 

 

 

 

 

For this example, a simple macro was created to analyze each timepoint automatically: 
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Phase Contrast Cells segmentation example I 
1. Remember to work always with a copy of your original images. 

2. For this example, a shading correction was applied: 

 2.1 Open, duplicate your image and rename it as Shading: Image>Duplicate… 
 2.2 Apply a gaussian blur filter to blur out cells (Radius 5): 
 2.3 Use Image Calculator to apply the shading correction: Divide original image by shading image (new,32bits) 
 2.4 Scale result image from 32 Bit to 8 Bit: Image>Type>8-bit 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Because thresholding segmentation is difficult for phase contrast images, an edge detection segmentation plugin was used: Image Edge plugin: 
 
 3.1 Download Image Edge plugin. Information on this tool can be found here: 
       http://imagejdocu.tudor.lu/doku.php?id=plugin:filter:edge_detection:start 
 3.2 Select your shading corrected image and go to Plugins>Image Edge>Deriche .Use an alpha value of 3 
 3.3 Keep the result image with sharper edges: Canny-Deriche suppr 3.0 
 
  
 

Raw Blurred (Shading image) Shading Corrected 

Edge detection 

PHANTAST: a plugin for automatic 
segmentation of phase contrast images 
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Phase Contrast Cells segmentation example II 
4. Scale result image from 32 Bit to 8 Bit: Image>Type>8-bit 

5. Now that the image is simplified, apply an intensity threshold to obtain a binary image (white edges and black background):        

 5.1 Image>Adjust>Threshold 

 5.2 Once the threshold range has been selected, click on Apply, to obtain a binary image: 

  

 

 

 

 

 

 

 

6. Use morphological operations to improve cell shape: Process>Binary>Options 

 Use Close and Fill Holes operations to  join cells borders and fill holes: 

 

 

 

 

 

 

 

Binary Thresholded 

Close Fill Holes 
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Phase Contrast Cells segmentation example III 
7. Apply a Median filter (Radius=3) to get rid of small pixels and to smooth contours: Process>Filters>Median… 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
8. Use Analyze Particles tool to detect individual cells regions: Analyze> Analyze Particles 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
9. You can measure different parameters from cells regions using the Measure button: 
 
Use Analyze>Set Measurements to define the parameters to measure 
 
Take into account that some of the cells might appear fused 
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2.3 K-clustering 
 
 Segments the image in ‘K’ number of clusters or regions with similar intensity 
 
 Number of clusters (K) must be defined by user  
 
 Can be used for colour images 
 
   

Plugin k-means Clustering 
 
 

2. Segmentation 

      Input Image                       K=2                             K=3                            K=4 
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http://ij-plugins.sourceforge.net/plugins/segmentation/k-means.html


2.4 Region Based  
  
 Classifies pixels based on its similarity 
 
 A certain number of Seeds or reference pixels must be defined by user 
 
 Algorithm increases iteratively seed area 
 
 
 Plugin Seeded Region Growing Tool 
 
 
  
 
  
  
 
  
 
 
 
 
 
 
 

2. Segmentation 

Raw Image + Seeds Result 
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2.5 Active Contours  
  
 
  
  
 
 
 
 
 
 
 

User specifies an initial contour around the object 
 
The curve is modified (it grows inwards or outwards) 
 until it reaches object boundaries 
 
 
 
 
Plugin Level Sets 
Plugin ABSnake 
Plugin E-Snake 
 

2. Segmentation 
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http://fiji.sc/Level_Sets
http://imagejdocu.tudor.lu/doku.php?id=plugin:segmentation:active_contour:start
http://bigwww.epfl.ch/algorithms/esnake/
http://bigwww.epfl.ch/algorithms/esnake/
http://bigwww.epfl.ch/algorithms/esnake/


2.6 Watershed 
Use to separate or cut apart particles that touch 
 
Binary Watershed 
Dilates as far as possible the point in the object located furthest from background 
 
 
Process>Binary>Watershed 
 

2. Segmentation 

Plugin Graylevel Watershed 

Grayscale Watershed 
 
Image seen as a topographic representation. ‘Flooded’ from below to above.  
When ‘rising water’ in adjacent basins is about to merge, a dam (Watershed line) is 
built to prevent merging.  
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2.7 Colour Image Segmentation 
2.7.1 Color Threshold 
Color based threshold segmentation 

 

 Image>Adjust>Color Threshold 

 

2.7.2 Colour Deconvolution 
Splits color image into separate channels based on 3 determined colors 

Some histological stains already defined (e.g., DAB, H&E, Masson trichrome) 

 

 

Plugin Colour Deconvolution 

 

2. Segmentation 
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2.7 Colour Image Segmentation II 
2.7.3 Color Segmentation 
Groups pixels with similar color properties  

Clusters are defined by user 

 

 Plugin Color Segmentation 

 

2.7.4 SIOX (Simple Interactive Object Extraction) 
Extracts foreground pixels (objects) from background pixels based on used defined regions 

 

 

Plugin SIOX 

 

2. Segmentation 
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http://bigwww.epfl.ch/sage/soft/colorsegmentation/
http://fiji.sc/SIOX:_Simple_Interactive_Object_Extraction


2.8 Trainable Segmentation  
2.8.1 WEKA 
It can be trained from user defined regions 

Creates a classifier to perform the same segmentation process in different images 

Plugin Trainable WEKA Segmentation 

 

 

2. Segmentation 
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Trainable WEKA segmentation example I 
1. If necessary, download and install Trainable WEKA Segmentation plugin. 

http://fiji.sc/Trainable_Weka_Segmentation 

 

2. Open the image or stack of images and WEKA plugin 

3. By default, classification is based only on 2 classes, but if needed more classification classes can be created clicking on the Create new class 
button. They can also be renamed going to Settings. 
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Trainable WEKA segmentation example II 
 

4. Using any of the drawing selection tools available, select image areas of the desired colour and assign them to a certain class (Add to Class) 

 

5. There are different training features in Settings that will be taken into account for  pixel classification. Increasing its number  will increase the 
time needed for processing. 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Click Train classifier to start pixel classification. 
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Trainable WEKA segmentation example III 
7. Use the Toogle overlay button to check segmentation accuracy 

 

 

 

 

 

 

 

 

 

 

8. If necessary, assign new image areas to the classes and repeat Train classifier for colour detection improvement 

9. Once an acceptable result is obtained, save your classifier (Save classifier) or apply it to other images (Apply classifier) 

10. Use Create result to produce the segmented image 
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2.9 3D Segmentation 
2.9.1 Segmentation Editor 
3D manual segmentation 

Interpolation between ROIs 

Labels can be combined with original image for 3D display 

 

Plugin Segmentation Editor 

 

2.9.2 Interactive 3D Segmentation 
Semi-automated 3D object  surface segmentation 

Surface generation process from user defined seeds 

3D viewer plugin needed 

 

Plugin Interactive 3D Segmentation 

2. Segmentation 
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http://132.187.25.13/home/?category=Download&page=SegmentationEditor
http://3dviewer.neurofly.de/
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http://132.187.25.13/ij3d/?page=IntSeg_3D&category=Extensions


2.9 3D Segmentation II 
2.9.3 3D ROI Manager 
3D threshold segmentation 

Detects 1 object even if it appears in different 2D slices 

3D measurements (intensity, volume, etc) 

3D Viewer plugin needed 

Plugin 3D ROI Manager 

 

2.9.4 Simple Neurite Tracer 
Semi-automatic 3D tracing and segmentation 

Optimal for neurons/tubular structures 

3D measurements (length, volume) 

3D Viewer plugin needed 

Plugin Simple Neurite Tracer 

 

2. Segmentation 
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Segmentation Editor example I 

1. If necessary, download and install Trainable WEKA Segmentation plugin. 

http://fiji.sc/Segmentation_Editor 

2. Open the Z stack and Segmentation Editor plugin 

3. New labels or segmented areas can be added if necessary (right clic of the mouse over a previous label) 

 

 

 

 

 

 

4. Segmented areas can be created by intensity thresholding: 

 4.1. Clic ‘T’ tool 

 4.2. Adjust min and max intensity value. If necessary, use the erode/dilate iterations slider to modify threshold result 

 4.3. A selection will be created around the thresholded pixels. Selection morphology can be modified with ‘O’ (Open) and ‘C’ (Close) . 
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Segmentation Editor example II 

5. Clic the 3d box if selection includes more than one slice of the stack.  

6. To assign the selection to one of the labels, clic ‘+’ button. 

 

 

 

 

 

7. Segmented areas can also be created manually: 

 7.1. Use any of the drawing tools to create a selection 

 7.2. Move to a different slice of the Zstack and draw another 

 7.3. Use the ‘I’ tool to interpolate the selection shape between the slices. 

 7.4. Clic the 3d box if selection includes more than one slice of the stack. To assign the selection to one of the labels, clic ‘+’ button. 
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Segmentation Editor example III 

8. Clic OK to finish the segmentation. 

 

 

 

 

 

 

 

 

 

 

 

9. A composite image can be created with the labels and the original image. 3D Viewer plugin can be used for 3D rendering. 
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Conclusions 

Image enhancement is a powerful tool for a better detection of 
image features but… use with caution!:  
 
 Final image must represent the original information 
 
 Check journal guidelines regarding image processing 
 
 
Great variety of segmentation algorithms… 
 
     Which to use? 
 
      Depends on your image 
 
 
 
Review of free software tools for image analysis of fluorescence cell micrographs (J. Microscopy 2015)  
 
Plugins ImageJ SMOC Web page 
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